Python Agent 兼容环境和功能列表

本文主要说明 OneAPM 的 Python Agent 的兼容性,安装方法,配置。

兼容性和安装要求

我们支持的应用服务器和应用框架如下表所示:

平台类型 支持列表
操作系统
  • Linux
  • Solaris
  • FreeBSD
  • MacOS X
Python版本
  • 2.6
  • 2.7
  • 3.3
解释器
  • CPython
  • PyPy
WSGI/中间件
  • uWSGI
  • mod_wsgi
  • FastCGI
  • Gevent
  • AJP
  • CherryPy
  • Gunicorn
  • SCGI
  • Paste
  • Waitress
  • Flask-Compress
  • WebError
Web框架
  • Django
  • Flask
  • Tornado
  • Bottle
  • Pylons
  • Pyramid
  • CherryPy
  • Web2Py
Web Service
  • Django REST Framework
  • Django Piston
  • Tastypie for Django
  • Cornice for Pyramid
模板引擎
  • Jinja2
  • Mako
  • Genshi
数据库
  • MySQL
  • Oracle
  • SQLServer
  • PostgreSQL
NOSQL
  • Redis
  • Mongodb
  • Memcached
分布式
  • Celery
  • Gearman
其他
  • Pysolr
  • Facepy
  • Dropbox
  • feedparser
  • httplib
  • httplib2
  • request
  • thirft
  • urllib
  • urllib2
  • urllib3
  • xmlrpclib

我们同时为一系列其他Python包和模块提供Instrumentation 。Instrumentation 覆盖区域包括:数据库查询、缓存请求和外部服务请求。这些结果会自动在web事务宕机和缓慢事务的事务Trace中出现。

不支持的WSGI框架

除了表格中列出的框架以外,某些特定的Python WSGI web框架暂时不受支持。

 

 

还有其他问题? 提交请求

您还可以采取以下方式解决问题: